Analytics reports update is delayed

Incident Report for Spark Hire Recruit

Resolved

The issue has been fully resolved and analytics reports have returned to regular functionality.
Posted Jul 18, 2025 - 16:20 UTC

Identified

The data update for Spark Hire Recruit Analytics reports is currently delayed. Our team is currently working on resolving the issue.
Posted Jul 14, 2025 - 19:34 UTC
This incident affected: Spark Hire Recruit Web Application.