Analytics reports update is delayed

Incident Report for Spark Hire Recruit

Resolved

The issue has been fully resolved and analytics reports have returned to regular functionality.
Posted Jul 23, 2025 - 05:28 UTC

Identified

The data update for Spark Hire Recruit Analytics reports is currently delayed for some of our clients.
Our team is currently working with AWS on resolving the issue.
Posted Jul 22, 2025 - 10:06 UTC
This incident affected: Spark Hire Recruit Web Application.